D850 in Live View mode, flash on TTL, non-CPU lens: "err"

Started 4 months ago | Questions thread
RafaelD7
OP RafaelD7 Senior Member • Posts: 2,182
Re: Error with D850 in Live View mode, flash on TTL, non-CPU lens

Wahrsager wrote:

RafaelD7 wrote:

Anybody?

“Laowa 60mm f/2.8 lens. The lens is fully manual (no electronics at all)”

Maybe asking in a macro forum would get you an expert answer.

I can only guess that since live view focuses via pixel edge (I think) rather than a separate phase detect mechanism, the third-party lens with no electronics isn’t giving the camera the information (such as distance) it needs to guarantee an exposure based on what you put in it.

This site may not answer your question, but there is a treasure trove of information about Nikon TTL in it:

https://scantips.com/

Thank you very much, good points. I suspected that the lack of distance information could be the cause, but then I didn't understand why it worked OK when shooting in normal (not Live View) mode through the viewfinder.

-- hide signature --

Regards,
Rafael
It's not what your camera can do for you - it's what you can do with your camera.
Instagram: @rafaelaviles
http://www.pbase.com/aviles
http://www.pbase.com/image/100392697.jpg

 RafaelD7's gear list:RafaelD7's gear list
Nikon D850 Nikon AF Nikkor 50mm f/1.4D Nikon AF-S Micro-Nikkor 105mm F2.8G IF-ED VR Sigma 150-600mm F5-6.3 | C Tamron 15-30mm F2.8 +1 more
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow