Need help w/ GR lllx

Started 1 month ago | Discussions thread
ForumParentFirstPrevious
Flat view
MacroDonata
MacroDonata Contributing Member • Posts: 556
Need help w/ GR lllx

Just got a refurb GR lllx from Ricoh.

Formatted the SD card, but every time I take a shot, I get this message: "Unable to store image" and the camera turns off.

It is a brand new PNY 16gb 10, u1 card, which came from a batch of five that I bought as emergency backups a few months ago.  No problems with any of those in several other cameras.

I took another card from the same batch of PNY cards out of my GR ll and reformatted it in the lllx and got the same result.  Put it back in the ll, reformatted it and it works as normal.

I have not yet attempted to format the card on my computer.

With no card in the camera, there is no issue using the internal memory.  At the moment, I have no other brands of cards to try.

I've also noticed movement inside the body when I simply turn the camera over to access the SD/battery compartment.  I'm certainly not handling the camera carelessly.  If I do the same while the camera is on, it is not noticeable.

As the return window is only 14 days for Ricoh refurbs, I'd like some feedback on these issues.

Thanks in advance.

 MacroDonata's gear list:MacroDonata's gear list
Ricoh GR II Sony RX100 V Sony a77 II Panasonic Lumix DMC-GM5 Olympus E-M5 II +23 more
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow