RX10 IV got rained on

Started 2 months ago | Discussions thread
ForumParentFirstPrevious
Flat view
Wolfgang Dempke Junior Member • Posts: 38
RX10 IV got rained on

I took my RX10 IV on a 3 hours hike and we, camera and I, got rained on very hard twice. Back at the car I wiped off the camera and was not too concerned because it is "weather sealed". Next day it did not turn on. I tried a different battery, still not turning on. My engineering friends suggested taking battery and SD card out, open all the little doors and let camera dry out inside the house. That brought it back to life for a day, then did not turn on. Let it dry out further and it seems to have recovered.

HOWEVER, now the battery drains within 24 hours from 100% to basically zero. I got a brand-new original Sony battery, same thing. 100% charge last night at 11 PM, just checked at 1 PM, 14 hours later it is down to 35% without having taken a single photo or video. A camera repair shop had opened the baseplate and did not see any moisture or corrosion. Something is drawing current and discharges the battery. As a "control" experiment I am testing one of the older batteries (less than 2 years old), the one that was not in the camera during the rain. I just insert it to test the charging status, then store it on my desk; it has held 100% for 5 hours.

Is there anything that drains the battery when inserted and the camera is not turned on? Shouldn't the charge stay at 100% while inserted as long as I don't take pictures or videos?

Anny suggestions are appreciated,

Thanks,

Wolfgang

 Wolfgang Dempke's gear list:Wolfgang Dempke's gear list
Canon PowerShot G11 Panasonic FZ2500
Sony RX10 IV
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow