Macro photoing with Canon 7D mark ii + Tamron SP 90mm (f004) not...working? Any advises?

Started 8 months ago | Discussions thread
ForumParentFirstPrevious
Flat view
winterwonderland Forum Member • Posts: 64
Macro photoing with Canon 7D mark ii + Tamron SP 90mm (f004) not...working? Any advises?

Ok, we're trying to experiment with some macro photography with our newly invested Tamron SP 90mm (f004 version) lens, mounted onto our Canon 7D mark ii, but what on earth are we doing wrong since it won't focus properly nor find the object if we get the lens TOO close to the object.

On the first photo, the lens doesn't find that yellow flower at all, since that's apparently too close. On the 2nd photo, which is further away from the object, it does find the object. We've tried to change between the 3 settings; full/inf, 0.5-inf and 0.3-0.5m, but it seems to be the same whatsoever. So, is there a specific setting on the camera itself that we should use? Does metering mode got anything to do with it? Any specific mode we should have it on?

We'd greatly appreciate some advises on what we can try out to get this to work properly! I am positive we're missing out on something "obvious", since we know that the learning curve and/or possibilities with the 7d mark ii are so many! And what better place to ask this than here with sooo many other skilled macro photographers!

Yes, she's trying out her DIY diffuser, but that shouldn't make any problems for her, or?

Canon EOS 7D Mark II Tamron SP 90mm F2.8 Di VC USD 1:1 Macro (F004)
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow