Pentax FA* 85mm - sticky AF

Started Jun 20, 2022 | Discussions thread
KPM2 Senior Member • Posts: 2,350
Re: last try of a maybe

Hello JawaT

JawaT wrote:

KPM2 wrote:

Hello again JawaT

JawaT wrote:

I am using AF-S.

That is such a nice lens, therefore my last try:

What happens in AF-S and LV AF ?.

This lens is at full open not very sharp and it has also a little focus shift and has at full open beside the main maxima focus point also beside maxima...and that is not so easy to handle for the AF of the camera. Of cause, my FA* 85 focus snappy in AF-S, but, and this is my last maybe: is the front lens or the back lens a little dirty, like a fine film is on it. That could irritate the phase AF, but a contrast AF in LV could live with it.

best regards KPM2

Well, AF was intermittent for a while, but now has stopped working completely. Regardless of whether I am using the viewfinder or Live View, it does not focus when set to Auto Focus.

When the trigger is pressed halfway, I can hear something whirring in the lens, but the lens focusing mechanism does nothing. Manual focusing works beautifully.

about this

I guess I have to get it serviced. Very likely, one or motor in the lens has failed.

The lens has no motor inside for the focus. It look's like that the mechanical clutch mechanism is defect (maybe some screw is loosely)  and do not couple to the AF gear.

I only send you this two pictures, for that you can compare the position of the pull and push ring:

manual focus position:

AF position:

The ring must reach this position, else the intern clutch do not couple to the AF gear.

Before you send your lens in, maybe look if your push and pull ring do can reach this AF position fully.

Sometimes I turne a very little and push the ring to get to this AF position. You hear a click sound than.

Thanks for all the suggestions.

JawaT

good luck and

best regards KPM2

Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow