Pentax FA* 85mm - sticky AF

Started 2 months ago | Discussions thread
OP JawaT Regular Member • Posts: 182
Re: Pentax FA* 85mm - sticky AF

KPM2 wrote:

Hello JawaT

JawaT wrote:

Got my hands on what appeared to be a good copy of Pentax FA* 85mm lens.

I think it had not been used for a long time. Would not operate in AF mode. Lens has a setting for AF. So I used it in the manual mode for a while, and kept on going back to AF. Now AF is working intermittently. May need to be serviced I guess.

Has anybody experienced this before? I would assume not, since why would anybody leave such a lens unused for any length of time!

JawaT

That is sad to hear.

When you set the lens clutch from manual to AF, do your camera show than also instead MF now AF in the OFV or info screen. If not and the camera still show MF, the first thing I would try is to clean the pin's on the bayonet.

When you pull the clutch from manual focus to AF, you can turn the clutch ring a little until it arrested, I do that always, but it is not a must to do, the AF is already at once active with my FA*85 when I did pull the clutch.

best regards KPM2

Sorry, I did forget to mention that I did clean the contacts on both the lens and the camera. The latter was probably not needed. I could hear the camera engage with the focusing mechanism but not be able to focus. The "focused" green square would continue to blink.

 JawaT's gear list:JawaT's gear list
Pentax KP Pentax smc DA 18-135mm F3.5-5.6ED AL [IF] DC WR Sigma 18-300 F3.5-6.3 DC Macro OS | C +3 more
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow