Flash disabled on Z9 -solution-

Started 4 months ago | Discussions thread
ForumParentFirstPrevious
Flat view
synmo Junior Member • Posts: 31
Flash disabled on Z9 -solution-
3

I ran into an issue when I first got my z9 of not being able to use a flash or trigger in the hot shoe, and I thought I would share the solution in case anybody else makes the same mistake.

When I received my camera, I did not like the shutter sound effect, so I went to the menus and turned on "Silent Mode" assuming it muted the sound effect. It DOES mute the sound effect, however it's a bigger setting than the the effect, it's about making the whole camera operate as quietly as possible. One of the things it does to ensure this is disabling the flash entirely.

All you have to do is disable silent mode. If you don't want the shutter sound effect, the mute and volume control for that is in the menu option directly above Silent Mode.

I shot a whole event thinking that I couldn't use my SB-800 with the Z9 and had it rigged to my Z7 instead as my flash body. It actually worked just fine for the event, but I'm relieved to still be able to use my flash, and triggers with the Z9.

I hope others can learn from my blunders!

Nikon Z7 Nikon Z9
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow