My new to me used X-Pro2 just broke after three days.

Started 4 months ago | Discussions thread
ForumParentFirstPrevious
Flat view
bs1946
bs1946 Veteran Member • Posts: 7,477
My new to me used X-Pro2 just broke after three days.

Basically, the curtain that blocks the front window of the viewfinder when I select EVF instead of OVF is stuck open. So the EVF image and data is barely visible.

The seller said he was selling the X-Pro2 because it was just sitting there after he went to full frame and in every other respect, the X-Pro2 is in mint condition, so I believe it is just my bad luck that it stuck now, perhaps from the cold or perhaps from lack of use. It worked perfectly for two days until I was out shooting late this afternoon in slightly above freezing weather. But bringing the X-Po2 back into the house and letting it sit for several hours, switching back and forth between EVF and OVF or whacking it with my hand as some people suggested in other posts for the same problem on X100 and X-Pro models have not corrected the problem.

I'm hoping somebody here knows some other methods to free up the EVF curtain because I don't relish having to send it off to Fuji.

-- hide signature --

Bill S.
www.flickr.com/photos/wrs1946
“Sharpness is a bourgeois concept”
- Henri Cartier-Bresson -

 bs1946's gear list:bs1946's gear list
Fujifilm X-T2 Fujifilm X-E4 Fujifilm XF 23mm F2 R WR Fujifilm 50mm F2 R WR Apple iPhone 12 Pro Max +1 more
Fujifilm FinePix X100 Fujifilm X-Pro2
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow