Dead R3

Started 1 month ago | Discussions thread
ForumParentFirstPrevious
Flat view
Fred Greaves
Fred Greaves Regular Member • Posts: 154
Dead R3
5

I had an R3 body suddenly die on a shoot last night. It was working fine and then it suddenly shut off.

I assumed it was a battery issue, so put a new battery in it and it still wouldn't power up.

I removed the lens (rf 70-200 2.8) and the memory cards and it still no luck.

I was not shooting at a fast rate, hires video, or anything that would have been close to strenuous for the camera. Plus it was in the low 50's so I was pretty certain it wouldn't have been an overheating issue.

I ended up finishing the shoot with my other body and used the dead one as a lens holder.

The battery, lens, and memory cards all work fine in the other R3... no issues.

Ultimately, the camera is bricked and will be on the way to CPS for repair. Hopefully they have the parts in stock to repair it in a timely manner.

The good news is that the images shot before it died all look good.

What's a little scary is that there were no error messages or any indication that the camera was having issues beforehand.

I was planning to sell my remaining R6 since I didn't see myself using it a lot now that I have the R3's... but after last night, I think I'll hold onto it for a while.

-- hide signature --

Fred Greaves
Photographer
www.fredgreaves.com

Canon EOS R6
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow