Topaz Sharpen AI

Started Jun 17, 2021 | Discussions thread
PMUK
PMUK Senior Member • Posts: 2,497
Re: Topaz Sharpen AI
1

domus wrote:

A truly weird thing happened.

I just upgraded to version 3.3.3 from 3.3.2, and the difference is *HUGE* on my old system. I never managed to make 3.3.2 do anything. 3.3.3 sharpened *A LOT* more out of the box.

First item on the release notes is "Fixed various image quality issues on older hardware."

That must have been my system.

Am throwing all the same stuff at it that failed before. Results are 100% more satisfying. Really lucky I downloaded 3.3.3 before abandoning it altogether.

Cheers,

Dom

Hi Dom,

That sounds very encouraging - and a nice reward for your perseverance!

I've just manually downloaded v3.3.3 and will have session trying it out on some favourites.

(One of the good things with Topaz is you can always download the latest versions off their site and - importantly - also roll back to an earlier version should an update veer off-piste).

Phil

[Edit]

First test - I just left it on full auto (which I never do - well, except for 'first tests' ).

It did a great job - and seemed maybe a little quicker too.

Before/ After -

Before

After

 PMUK's gear list:PMUK's gear list
Sony RX10 IV Sony RX100 VI Canon EOS 7D Mark II Canon EOS 5D Mark IV Canon EOS R5 +14 more
Post (hide subjects) Posted by
(unknown member)
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow