MX shutter speed disc not reading correctly

Started 1 month ago | Discussions thread
ForumParentFirstPrevious
Flat view
Michael Floyd Regular Member • Posts: 435
MX shutter speed disc not reading correctly

Hi everyone,

I've just received a new to me Pentax MX.  I haven't owned this model before and thought it was about time.

The camera looks pretty clean and all seems functional and problem free. I'll have to replace light seals and mirror bumper but that is to be expected.

One thing that it would be great to sort out though is the Shutter speed readout disk in the viewfinder is misaligned with the actual Shutter speed as set on the top dial.  The disk always reads one stop faster than the top dial.

I'm not the least shy of opening the whole thing up and doing the job, I'm just wondering if anyone has any link to any info on, or experience with, this particular issue before I get stuck into it. Perhaps there is a way to realign things without getting to the disk unit, or perhaps it is more pain than it is worth...

I popped the top off this afternoon on a little scout mission, other than deteriorating foam everything looks great.  The disk unit looks to be quite buried in there though, hence my query here today.

Cheers,  Michael.

 Michael Floyd's gear list:Michael Floyd's gear list
Fujifilm GFX 50R Fujifilm X-Pro3 Fujifilm XF 18-55mm F2.8-4 R LM OIS Zeiss Loxia 50 +6 more
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow