Dead or stuck pixel on Z6 II?

Started 2 months ago | Discussions thread
ForumParentFirstPrevious
Flat view
sirhawkeye64 Veteran Member • Posts: 7,281
Dead or stuck pixel on Z6 II?

Here are three crops at 100% of some recent images I took (they were around ISO 5000, which is higher than I normally shoot on a regular basis). No edits have been made to these images, as they are screen captures from the RAW processor.

The "green" area (when zoomed in appears like a "cross hair" and is not a block or a single pixel) appears in the same area in the frame on all images. It's not visible in areas that are not shadows. It seems that I can fix this in DXO Photolab by adjusting the Dead Pixel slider to a value of 4 or 5 or when noise reduction is applied (as Prime/DeepPrime may see these pixels as noise).

Has anyone else run into this on their Z cameras? Thoughts on this? I can send it in as it is still under warranty but I'm wondering more or less if this is common on cameras and maybe I just never noticed it...

I may do some further testing with a more static scene (this was shots I did during an urbex event so I was not on a tripod and the lighting was different for each shot.) I might do a static test at various ISOs to see if the issue arises only at certain ISOs or is the same. (I'll probably try do this against a white wall in low-light to simulate what is shown here).

(Note: Because I was using a screen clipping program, the dot may not appear in the exact same spot in the 100% clips but it does appear to be in the same spot when I cycle back and forth between images in Photolab, so the movement of the dot is because of how I did the screen clips.)

-- hide signature --

(NOTE: If I don't reply to a direct comment in the forums, it's likely I unsubscribed from the thread.)

 sirhawkeye64's gear list:sirhawkeye64's gear list
Nikon Z6 II Nikon Z7 II GoPro Hero8 Black Nikon Z 50mm F1.8 Nikon Z 14-30mm F4 +9 more
Nikon Z6 II
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow