Was looking for a reason to upgrade my OS from 10.14.6...

Started 2 months ago | Discussions thread
ForumParentFirstPrevious
Flat view
maccam
maccam Senior Member • Posts: 1,324
Was looking for a reason to upgrade my OS from 10.14.6...

...and I think I just found one. I'm running a 5 1/2 year old iMac and still clinging to OS 10.14.6 because I still use some 32bit aps. I am on the Adobe photography plan and today Adobe informed me that all of my aps had an upgrade coming. Great except that Photoshop 23.0, Bridge 12.0, and Lightroom Classic 11.0 cannot be upgraded to because my computer is "Not Compatible". I use Lightroom almost every day. Adobe didn't specify whether it was my operating system being out of date or my hardware or both. I'm guessing its just my OS. Does anybody know if Adobe was just referring to the OS?

I realize that older hardware sometimes just isn't up to the task of running newer software so I have my eye on a 16 inch MBP but I want to get my iMac running "a" newer OS but maybe not "the" latest OS 12. I'd like to do the OS upgrades in increments.

So, my first question; is it just the OS that needs to be upgraded for my Adobe plan to accept upgrades? The 2nd question: Anybody have any idea how I can upgrade my Mac OS in increments?

Thanks for any help

JAW

 maccam's gear list:maccam's gear list
Sony RX100 VI Sony Alpha NEX-5N Sony Alpha NEX-6 Sony a5100 Sony a6500 +14 more
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow