Canon PRO 300 - Professional Print & Layout won’t register printer

Started 1 month ago | Questions thread
ForumParentFirstPrevious
Flat view
kurtizone Forum Member • Posts: 61
Canon PRO 300 - Professional Print & Layout won’t register printer

I installed this plug-in in Lightroom (latest version) . When I select it, it tells me that no printer is registered. When I tell it to register the printer, I get the ‘Add Printer’ window, but the PRO-300 isn’t there. When I select ‘Find Printer’, it lists the printer in the ‘Printer List’ window, but the  the ‘OK’ button is greyed out.

What’s wrong?

A 2nd problem:

I’m doing this because the Canon (a week old) generally does a great job printing, but skin tones are too reddish-orange.

My Mac is calibrated with a Datacolor Spyder Elite device, and I print using the correct ICC profiles for the paper I’m printing with. That is, I print a soft-proof copy of the photo via the paper’s ICC profile. Skin tones look fine on the monitor.

I’m hoping that I can use the colour corrections in the PP&L plug-in to decrease the saturation of red/orange. However, I’m aware that, if I’m giving control over printing to the ICC profile, the Canon PPL plug-in may not be able to correct the red-orange colour cast.

Thanks for any help.

 kurtizone's gear list:kurtizone's gear list
Ricoh GR II Olympus E-M1 Panasonic Lumix DMC-GX8 Fujifilm X-T3 Fujifilm XF 18mm F2 R +3 more
ANSWER:
This question has not been answered yet.
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow