Need help, 7d Mkii focus screen not lighting up and blury

Started 2 months ago | Discussions thread
Sue Anne Rush
Sue Anne Rush Senior Member • Posts: 3,856
Re: Need help, 7d Mkii focus screen not lighting up and blury
1

Hello...

ZekeinSF wrote:

Hi all,

Forgive me but I have done searches for this problem and while finding a post from 2012 that was identical to mine, we were never given a resolution. Any help offered would be great! Here's the problem:

When looking through my cameras viewfinder it looks as though the camera is switched off or no battery installed. The viewfinder looks dead. However I can take pictures but there is no focus confirmation squares lighting up but rather a diffuse red blur that is coming from the top of the frame. this blur stays on for the same amount of time as the ficus confirmation/focus points normally would. The camera still beeps to give focus confirmation, will focus fine in live view, and even the photos taken through the viewfinder are in focus, however they are a bit over exposed for some reason. It isn't the diopter as it isn't that kind of blurry but rather that type of blurry you see when you lift the camera to your eye look through the viewfinder and realize you haven't turned the camera on yet. I know I'm being redundant but I can find no information about this particular problem but for this forum posted a decade ago. Oh, and I have also checked the focusing screen and it appears fine and is properly mounted. It happened two weeks ago when I reset the camera afterward looked as through the problem was solved. Unfortunately it came back a few days later and that's where I'm at. Any ideas?

IDK - but can you take it to the nearest photoshop to get it fixed. ? 

-- hide signature --

?

Sue Anne Rush

 Sue Anne Rush's gear list:Sue Anne Rush's gear list
Panasonic Lumix DC-FZ1000 II Canon EOS 7D Canon EOS-1D X Mark III
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow