LP-E6 not working on 7D Mark II.

Started 1 month ago | Questions thread
ForumParentFirstPrevious
Flat view
Joel0ZS
Joel0ZS New Member • Posts: 17
LP-E6 not working on 7D Mark II.
1

So, today I was photographing with my 7D Mark II and BG-E16. My genuine LP-E6N battery was working fine, but it ran out of power. So, my camera started to use my genuine LP-E6 battery, and when I tried to take photos, the camera turned off, top screen showing the battery is empty. I tried to turn my camera back on, and it shows that the battery has 75 % of charge, condition is 2/3. It works fine otherwise, but whenever I try to take photos, the camera turns off saying '' no battery''. The camera says there is 75 % of the battery left, and it doesn't change. The battery I have problems with is genuine LP-E6, manufactured in 2013. Do I really need to spend 60 € on a new battery? I don't have a lot of spare money because I am a student.

Thanks for answering!

-- hide signature --

Joel Karnio

 Joel0ZS's gear list:Joel0ZS's gear list
Canon EOS 7D Mark II Tamron AF 18-200mm F/3.5-6.3 XR Di II LD Aspherical (IF) Macro Tamron SP 70-300mm F4-5.6 Di VC USD Canon EF 50mm F1.8 STM Tamron SP 150-600mm F5-6.3 Di VC USD G2 +5 more
ANSWER:
This question has not been answered yet.
Canon EOS 7D Mark II
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
Post (hide subjects) Posted by
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow