D7200 problem with Lexar 64GB SD cards

Started 3 months ago | Discussions thread
OP nbirkett Senior Member • Posts: 1,966
Re: D7200 problem with Lexar 64GB SD cards

Blufftonian wrote:

At least it sounds like the problem is not with the D7200.

I have a 64mb SanDisk Extreme PRO 64GB 170MB/s card in my D7200 (and a SanDisk Extreme 32GB 60MB/s in slot 2) and I’ve never had any issues. I guess the good news is that SD cards are now pretty inexpensive, I just bought a 128GB SanDisk for $35 from Amazon.

My set-up is similar: 64Gb Lexar Professional 1000x 150MB/s card (and a Lexar 32GB Pro 400x card in slot 2).

You are right about the pricing - much lower than XQD cards. I'm more worried about the lost images and whether this might indicate a pending failure of the sd card reader in my camera.

I did have a fairly new Sony XQD card fail recently in my D500. I tried all sorts of recovery software without success. Fortunately Sony replaced it under warranty.

I had a SanDisk card fail a couple of years ago after a static electricity discharge when I was putting the card into my computer sd slot. One of the reasons that I have been using Lexar.

-- hide signature --

Nick

 nbirkett's gear list:nbirkett's gear list
Nikon D90 Nikon D7200 Nikon AF-S DX Nikkor 35mm F1.8G Nikon AF-S Nikkor 70-200mm F4G ED VR Nikon AF-S DX Nikkor 16-80mm F2.8-4E ED VR +6 more
Post (hide subjects) Posted by
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow