X-T4: Anyone problems when upgrading from 1.11 to 1.22, too?

Started 2 months ago | Questions thread
ForumParentFirstPrevious
Flat view
Rightsaidfred
Rightsaidfred Senior Member • Posts: 1,167
X-T4: Anyone problems when upgrading from 1.11 to 1.22, too?
2

Dear Fujians

So I don't exactly like firmware updates, I am always a bit nervous. But in fact, having been a Fujifilm user for almost 3 years, having upgraded my X-T20, my XF lenses, my Viltrox 23 mm f/1.4 lens multiple times, I never had an issue.

But now there is

I had just decided to upgrade from my X-T20 to an X-T4, using the current 200 € cashback campaign in Germany. Wow, what a build quality! Breathtaking! But my X-T4 review will come later. Imagine I did not take a single picture yet!

On Tuesday, I happily received my brand new X-T4. The seal was unbroken. Charged the battery in the camera, did just a few first menu settings, and then checked the firmware. It was 1.11. So I downladed 1.22 from the Fujifilm website, copied it to a brand new Sandisk Extreme Pro SDXC UHS-1 170 MB/s card that I just before had formatted in the X-T4, and proceeded to install the new firmware. Same procedure as always, exactly following the instruction, pressing the display/back button while switching the camera on.

Well. And then there came this message on the brand new X-T4's screen:

Alert after trying to upgrade brand new X-T4 from 1.11 to 1.22

OMG

Then I tried to update through the Fujifilm remote app. Then again through sd card. Downloaded the *.dat file again just to be sure. Took the battery out. Used another sd card. Used one sd card only in slot 1. Always the same result.

When I tried to turn on the camera, it always said, "! Turn off the camera and turn on again". In fact, my brand new X-T4 was dead before I had taken the first picture

Called Fujifilm the other morning. They said, well, seems like a technical issue, it's brand new, so return it to the seller. Did so immediately. Looks like I'll now receive a brand new X-T4 again. So obviously the seller was unable to upgrade the firmware, too.

Still waiting for my replacement but I am a bit nervous about the upcoming firmware update. Because I have no idea what the heck could be a reason for the firmware update failure with my first sample.

Here comes my question. Has anyone experienced a similar issue?

I am aware of the post, Freezing issues XT4 - "Has anyone updated to the latest firmware of the XT4 and experienced any freezing issues?" but that is a different topic.

Edit. I had activated the bluetooth pairing before upgrading. There was obviously a problem with v1.21. See X-T4 New Firmware 1.22. So next time I will NOT pair before upgrading.

Any tips? Thoughts?

Kind regards,

Martin

 Rightsaidfred's gear list:Rightsaidfred's gear list
Fujifilm X-T20 Fujifilm X-T4 Fujifilm XF 35mm F1.4 R Fujifilm XF 18-55mm F2.8-4 R LM OIS Fujifilm XF 55-200mm F3.5-4.8 R LM OIS +6 more
ANSWER:
Fujifilm X-T4
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
Post (hide subjects) Posted by
rlx
rlx
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow