HELP! My A77 has gone mad!

Started 2 months ago | Discussions thread
ForumParentFirstPrevious
Flat view
Photorer Senior Member • Posts: 1,436
HELP! My A77 has gone mad!

OK - well its really my daughter's now.....

She is off to the bush this week, for a special safari for her 21st birthday. She prepared on Monday to leave by taking out the A77 and 70-400G and turned it on... battery totally dead (of course! )

She charged the battery full, and put it in - only to find that the camera doesn't work properly any longer. It takes a looong time to "wake up" and then the back screen is slow to respond. When you try to get focus, it simply does not respond, or it cycles to infinity and back again then the screen goes light grey (or misty white). Then it freezes and no controls work. Turn it off, and back on to the same issue.

The only way to try and get out of this cycle is to remove the battery and then replace it. Then the same happens again......

No way of taking a still shot or any viewing of images on the SD card....

Its now quite an old machine, and I know that Sony in South Africa will simply laugh at me wanting to repair it.....

Does anyone know if there is perhaps some technique of reviving the old girl?

-- hide signature --

Still not enough time to take pictures....... Is there ever?

 Photorer's gear list:Photorer's gear list
Sony SLT-A77
Sony SLT-A77
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow