Canon Pixma Pro 100s: ink 1/4 gone after 10 small prints

Started 2 months ago | Discussions thread
ForumParentFirstPrevious
Flat view
Classick
Classick Forum Member • Posts: 52
Canon Pixma Pro 100s: ink 1/4 gone after 10 small prints

Hello printer & printing folks,

Three weeks ago I purchased a new Canon Pro 100s from John Lewis, UK. I know that these printers are not cheap to run but I am concerned how the Supply Level is showing me ~1/4 used after printing ten 6x4 photos and one single A4 photo (mixture of colour and B&Ws). The details:

- I have printed on Canon Photo Paper Plus Glossy 2 paper.

- I am using the original Canon ink cartridges.

- For half the prints I did them directly from my iPhones AirPrint, but stopped this due to poor print quality (images were dull).

- The other half I have printed from the Macs native Preview application. I set the correct paper type and size.

It seems to me there are 3 options:

1. This the sort of ink duration I can expect, and at this rate, the ink will run finish by about 40 small 6x4 photos. This does not seem right.

2. There is a problem with my printer/ink

3. The Macs Supply Level preview is not accurate.

Hoping someone with experience printing with the Pixma Pro 100 can help me work out what maybe going on? I have attached

As always, many thanks!

 Classick's gear list:Classick's gear list
Nikon D500 Leica CL Nikon AF-S DX Nikkor 35mm F1.8G Nikon AF-S DX Nikkor 17-55mm f/2.8G ED-IF Nikon AF-S Nikkor 58mm f/1.4G +2 more
Canon Pixma Pro-100
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow