EM1.1 Rear Dial Issue --- not again

Started 4 months ago | Discussions thread
Albert Valentino Veteran Member • Posts: 9,256
Re: EM1.1 Rear Dial Issue --- not again
4

Had this problem six months after buying a new model in late 2016 at the end of the production run. Fiddled with it for short term usability but then brought it in to Olympus in Nj for repair. I said this is a known issue, and they did not hesitate to agree and replaced dial.

Since this is a known issue with the mark I, as well as the strap lugs falling off, they should fix it for free. And there have been threads here and there over the years with the same issue occurring out of warranty and being fixed with no charge. That said, I suggest you go on the offensive and call and find the right person to state that a known design flaw has occurred and it has been your understanding that this is often fixed without charge. Be insistent, you have nothing to lose by trying and are, more or less, within your rights fora free repair, or settle for a reduced fee. $250 to repair is about what the camera would sell for after fees.

-- hide signature --

If you don't get older and wiser, than you just get older.

 Albert Valentino's gear list:Albert Valentino's gear list
Olympus E-M1 III Olympus M.Zuiko Digital ED 40-150mm F4-5.6 R Olympus M.Zuiko Digital 45mm F1.8 Olympus M.Zuiko Digital ED 60mm F2.8 Macro Olympus M.Zuiko Digital 25mm F1.8 +10 more
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow