My Film mistakes!!!

Started 2 months ago | Discussions thread
ForumParentFirstPrevious
Flat view
photoholiko Veteran Member • Posts: 3,101
My Film mistakes!!!

First let me show you the equipment I used. I want to say that it performed well, it's just the slide I was copying weren't good.

Correction, Cannon 50mm/f1.4

I scanned some slides taken some years ago and was shocked by how bad they were. I used good equipment at the time which means it was mostly my fault.

Mistake #1;

In 1973 my second daughter was born. I was excited to find some Ansco 800ASAfilm which was to give me proper exposure. The results of this ounce in a life type photo shoot turned out to be garbage. Under exposed and very grainy. I felt so bad that my wife felt sorry for me and refrained from criticizing me.

Mistake #2;

A few years later I went on an extended trip to Europe, i thought I would use a European film (Agfachrome) The equipment was Cannon F1 and Vivitar 70-210/f2.8. Apart from my out of focus and under exposure, the slides had a purple cast to them, granted the weather wasn't always good but still. The only salvation is for me to convert them to B&W.

Some Samples.

Amsterdam

Lubeck, Germany.

Netherlands

Thanks for looking, comments are welcome!

 photoholiko's gear list:photoholiko's gear list
Canon EOS 400D Olympus PEN E-PL1 Epson PhotoPC 850 Zoom Minolta DiMAGE 7 Panasonic Lumix DMC-FZ200 +34 more
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow