Auto ISO show number on display

Started 4 months ago | Discussions thread
Ranlee Senior Member • Posts: 2,070
Re: Auto ISO show number on display
1

detroit1 wrote:

I have it on M and auto ISO max 6400 but the display will not show the ISO number

Someone else I asked emailed me back and said you can't see that in this case

Please let me know if there is any setting or something to try in this case

As alcelc stated above you should see the ISO value when you initiate metering via half-press shutter or however.  It is not a dynamic display of ISO, in other words it will not change when you re-aim the camera at a different light source unless you again initiate metering via half-press.

On M and auto ISO you should see the ISO on half-press if you are not some other setting might be interfering although I can't think of what that might be.  I would recommend saving your settings to your SD card and then do a camera reset to factory default.  If ISO then works as described above  (as it should) you likely did have another setting interfering.  Start adding in your custom settings from before manually until one of them causes your problem to reappear.  You will have found the culprit.  If, after reset it still doesn't work you can at least reload your settings from the SD card and not have lost any ground.

-- hide signature --

Randy

 Ranlee's gear list:Ranlee's gear list
Panasonic Lumix DMC-GX8 Panasonic Lumix DC-G9 Canon EF 200mm f/2.8L II USM Olympus M.Zuiko 300mm F4 IS Pro Panasonic Leica 12-60mm F2.8-4.0 ASPH +6 more
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow