Screen glitch on startup after OS upgrade

Started 3 months ago | Questions thread
ForumParentFirstPrevious
Flat view
Lettermanian
Lettermanian Senior Member • Posts: 1,898
Screen glitch on startup after OS upgrade

Yesterday I upgraded (🤔) my 2014 MacBook Pro 13" to Big Sur from Catalina, preparing to sell this older MacBook. Now on startup, I'm getting a very brief screen glitch, happening just before the progress bar gets to the halfway point. The glitch lasts for about 1/2 second, then the progress bar speedily finishes and opens the home page as per normal this wasn't happening with Catalina. Things I tried:

- ran diagnostics (start then hold down "D" key). No issues found.

- reset SMC

-reset PRAM

- ran disk utility and first aid

- now re-installing Big Sur.

Any idea of what might be happening? Photos below. Pay no attention the man behind the screen... 😁

Just before the brief glitch

Glitch. After this the start process finishes quickly. There are no hints of anything wrong with the screen in normal operation.

-- hide signature --

"Be yourself. No one can say you're doing it wrong." -Charles M. Schulz
"I love mankind... it's PEOPLE I can't stand!!" - Linus

 Lettermanian's gear list:Lettermanian's gear list
Fujifilm X-H1 Carl Zeiss Touit 2.8/12 Fujifilm 16-55mm F2.8R LM WR Fujifilm XF 70-300 F4-5.6 R LM OIS WR
ANSWER:
This question has not been answered yet.
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow