Sony a7riii and godox x pro suddenly stop communicating...? I'd love some insight.

Started 1 month ago | Discussions thread
ForumParentFirstPrevious
Flat view
Amanda_Taylor New Member • Posts: 4
Sony a7riii and godox x pro suddenly stop communicating...? I'd love some insight.

****UPDATE*****

I posted this in the questions thread last week, but I didn't get any responses so I thought I'd repost in the main section just in case no one saw it.  I did go to my local camera store, and it was a little less than enlightening.  He googled the issue and saw my post about it.  I have the option to send it out for repair, but I'm not sure that there's anything to repair...  I'm convinced I toggled something in the menu by mistake and I can't find the error....

Hello

As I mentioned in the title, I have an A7riii. I am currently using a Godox x pro trigger and Godox strobes. TWO DAYS AGO this set up worked like a dream. Last night I went to test out a few set ups for an upcoming shoot and.... nuthin'. Here's where I'm at diagnostically:

EFCS: OFF

Mechanical Shutter: ON

Flash Mode: FILL FLASH

Anti-flicker Shoot: Have tried with this on and off and observed no change

Exp. Comp. Setting: AMBIENT ONLY

Wireless Flash: Previously this has always been on, but today I switched it off and observed no change

External Flash Setting: I do not remember touching this in the past. The sub menu for external flash firing settings and custom settings are both greyed out and a pop up stating that the external flash is either not supported or not installed properly shows up when I try to "click" on either. This wasn't immediately concerning because I am using a non native system, but I've tried everything else today so now I'm not so sure...

Other observations:

The camera icon appears on the x pro and the flash symbol with an amber dot next to it appears on the camera when the two are connected and powered on. I have taken this to mean that both the trigger and the camera are aware that the other exists. Is the amber dot something to note? I don't normally shoot with the display that shows this so I have never looked for it in the past and don't know if the dot should be another color.. like, say, green?

The x pro will fire the strobe when the test button is pushed and it will adjust the power of the strobe remotely.

What I can't for the life of me figure out is why pressing the shutter does not fire the strobe. Can someone help me with this?

I have even changed the batteries... just in case, but alas...

I did a live chat with Sony today and after preforming a factory reset of the camera they said to go cry to Godox. Something tells me that isn't gonna work out.

help....?

 Amanda_Taylor's gear list:Amanda_Taylor's gear list
Sony a7R III Sony 50mm F1.4
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow