K3III firmware 1.01 ?

Started 1 month ago | Questions thread
Valeriu 64
Valeriu 64 Veteran Member • Posts: 3,938
Re: K3III firmware 1.01 ?

MightyMike wrote:

First off, go into sensor cleaning mode and take an air blower and blow the area at the bottom of the mirror box a good amount to knock any dust out of there. Secondly take a dry cloth and give the contacts on the camera mount and lens a good wipe down. The try it out again, if the issues persist then there may be other problems that could be hard to diagnose and pin down.

Should it be blown under the mirror, exactly on the sensor?

Can't blow dust into the camera?

I also blew a few years ago at the K5 with a photo pump and it was filled with dust and lint, inside the focusing screen glass.

-- hide signature --

Mike from Canada
"I am not a great photographer! God is a great creator! All I do is capture His creation with the tools He has provided me."
'I like to think so far outside the box that it would require a telephoto lens just to see the box!' ~ 'My Quote :)'
http://www.michaelfastphotography.com/galleries/VP-BDI_3a.jpg
http://www.airliners.net/user/SpeEedy/profile/photos?sortBy=photoFavoriteCount

 Valeriu 64's gear list:Valeriu 64's gear list
Pentax K-1 II Pentax K-3 Mark III Sigma 70-200mm F2.8 EX DG Macro HSM II Pentax smc D-FA 100mm F2.8 Macro WR Pentax smc DA 18-135mm F3.5-5.6ED AL [IF] DC WR +8 more
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow