Is my DSC RX 10 m 4 defective?

Started 2 months ago | Questions thread
User6927265519 Regular Member • Posts: 202
Re: Is my DSC RX 10 m 4 defective?

There are no camera settings that would cause or resolve that fault but with a bit of luck it seems like it may have resolved itself just from use, if this is the first time you used the camera maybe the lens mechanism was a little tight and needed to be operated a few times to bed in  (I had a real problem removing the lens hood on mine when I first got it because it was so tight which I put down to newness, but after a couple of uses it freed itself up fine),

I do hope this is the case and you never see this fault rear its head again, in my experience most faults with modern electro/mechanical equipment in general occur during early days of use but if it does reoccur I would suggest you maybe video the fault before you do anything else then send the camera back as having an intermittent fault along with the accompanying footage as proof. I would suggest that because it it only 3 months old then don’t try and fix it or waste your time with tech support asking you “is it switched on” etc, it should be repaired or replaced under warranty.

I am no expert so just my opinion fwiw.

 User6927265519's gear list:User6927265519's gear list
Sony Cyber-shot DSC-H5 Sony RX100 II Sony SLT-A57 Sony Alpha NEX-6 Sony a77 II +3 more
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow