Lightroom / CFExpress A / Import via ProGrade Digital Reader Issues

Started 1 month ago | Discussions thread
ForumParentFirstPreviousNext
Flat view
Schwa
Schwa Senior Member • Posts: 1,255
Lightroom / CFExpress A / Import via ProGrade Digital Reader Issues
1

I apologize if there's a better forum but I figured since I'm using a CFExpress A card for the first time with my a1, y'all would probably know the answer.

I'm using the ProGrade Digital reader recommended here by others but I am having some issues importing w/ Lightroom. When I import directly from the camera via my USB-C cable, everything works as expected (imports to my folder, creates new one with date, etc...)

However, when I try to import from the card via the external reader, I am can no longer choose (or even see) the destination folder and it actually imports oddly enough right back to the CF-A card in the reader.

Has anyone else seen this behavior? Windows (10) seems to think the card is also a local disc and not a usb device that can be ejected. When I called the ProGrade peeps about this they said this is normal behavior and I should just copy all the photos from the card to my local disc and then just import them from there, which seems like a ridiculous solution.

Can anyone shed some light onto this issue or share w/ me your workflow w/ Lightroom, CF-A cards, et al?

Thanks in advance.

 Schwa's gear list:Schwa's gear list
Sony a7 III Sony a1 Apple iPhone 12 Pro Max Apple iPad Pro
Sony a1
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNext
Flat view
Post (hide subjects) Posted by
ForumParentFirstPreviousNext
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow