X-T30 & EF-FX1 Adaptor Issues Help

Started 1 month ago | Questions thread
ForumParentFirstPrevious
Flat view
JustinArkinson New Member • Posts: 3
X-T30 & EF-FX1 Adaptor Issues Help
1

Hi all

Looking for some help.

I have just upgraded my X-T1 to an X-T30 and having issues with my EF-FX1 Adaptor.

On my X-T1 everything works great. Focus, aperture - no issues at all. Love it.

On my X-T30 I can focus and change aperture no problems. The only issue I have is when I go into the View mode and exit it. The screen constantly flickers black and is unusable. The camera locks up and I have to turn it on and off.

This does not happen if I don't go into the View mode. I have a video I uploaded to YouTube but not sure how to attach.

I tried to attach but my post didn't appear.

I have tried all my Canon lenses, 50mm 1.8, 24mm 2.8 and 40mm 2.8. All of these are the same.

I have updated the firmware on the adaptor and the camera but still the same issues.

Is there a setting I need to change on the camera? I have tried Manual lenses and these work fine.

Any help would be great.

https://youtu.be/8crH4PZ7RUg

ANSWER:
This question has not been answered yet.
Fujifilm X-T1 Fujifilm X-T3
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow