Viltrox rf-ef adapter issue

Started 3 weeks ago | Discussions thread
ForumParentFirstPrevious
Flat view
Pbrianl New Member • Posts: 7
Viltrox rf-ef adapter issue
2

Just a heads up to Viltrox users.

Been using my ef 100-400 L mkii for the last couple of weeks with the standard Viltrox adapter without a problem. Today I changed to this lens and the adapter would not lock onto my R6 at all. Tried several times without success. On my last attempt a very small screw fell out from somewhere, luckily it fell into my lap and I was able to find it. Tried the adapter again and it locked but would also rotate past the locking point so this small screw is a stop point. I managed to locate on the adapter where it was from and reinserted it with the aid of a magnifying glass. The adapter now locks onto the camera without a problem. 
The screw is very small, less than 1mm in size and if I had changed lenses in the field I would have been stumped. I will keep checking it from now on to make sure it remains secure. Cmon Canon get your act together and get the official adapter in stock in the UK, I am on a waiting list but suppliers cannot tell me when it will be back in stock. 😡

 Pbrianl's gear list:Pbrianl's gear list
Canon EOS 7D Mark II Canon EOS R6 Canon EF 17-40mm f/4.0L USM Canon EF 100mm F2.8L Macro IS USM Canon Extender EF 1.4x II +3 more
Canon EOS R6
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow