Olympus PEN-F & Olympus FL36 Flash not working

Started 4 weeks ago | Questions thread
ForumParentFirstPrevious
Flat view
matejspanik
matejspanik New Member • Posts: 4
Olympus PEN-F & Olympus FL36 Flash not working

Hello,

I have an Olympus PEN-F camera and I would like to use a bit more advanced flash. I bought an Olympus FL36 flash based on the Olympus website is stated that these two should be compatible and safe to use.
https://cs.olympus-imaging.jp/en/support/imsg/digicamera/compati/pen_flashes.cfm

But in reality, the flash doesn't work when taking the photos.

The camera is set in Manual mode and the flash is in TTL Auto (although I tried also Auto and Manual mode as well).

On display the I icon of flash so the camera knows that flash is attached, plus also I am able to choose from Full Flash, Red eyes and 2nd Curtain options. And also flash seems to react to the camera as well (when the camera switch off the flash will turn into sleeping mode as well). The flash doesn't light when pulling the trigger.

I tested the flash on other cameras and it works. Also, batteries are new, the flash is reloading relatively fast, and also test flash button works ok. Also, I tried the Camera with FL-LM3 flash and with that one it works as well.

I went through all the suggestions that are stated here:
https://www.olympus.co.uk/site/en/c/cameras_support/repair_service/pre_repair_check/pre_repair_flash.html

But nothing helped.

I would be happy for any help from you guys because I am getting really frustrated and I don't understand what can be wrong.

Thanks in advance!

Matej

ANSWER:
This question has not been answered yet.
Olympus PEN-F
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow