Luminar issues

Started 2 months ago | Discussions thread
ForumParentFirstPrevious
Flat view
KLH475 Senior Member • Posts: 1,575
Luminar issues

Hello Retouchers,

I recently paid for and downloaded the newest iteration of Luminar - Luminar AI. From the reviews and Ytubes I watched it looked like a good addition to PS/LR and DxO for the fun part of editing. I went through the installation process and clicked on "Launch" when the program finished insatalling and then ---> nothing. I opened Photoshop, opened a photo, scrolled down the Filters list to Lumninar, clicked and -----> nothing. I rebooted a couple of times, I uninstalled the program and reinsalled it and it never opened and it didn't show up in Task Manager as having any processes open/active although the desktop icon showed up as did the Item in the FIlters menu. I emailed Luminar and told them this, asked for a refund and, to their credit, less than 12 hours later they have credited back my credit card.

This morning I did a search for "Luminar won't open" and found many sites filled with my exact experience from many others. Has anyone reading this had the same experience and somehow persisted and ended up with a fully working version of Luminar?

Thank you,

Ken

 KLH475's gear list:KLH475's gear list
Nikon Z7 II Nikon AP-F 70-300mm F4.5-5.6E Nikon Z 24-70mm F4 Nikon Z 50mm F1.8 Nikon Z 85mm F1.8 +3 more
ForumParentFirstPrevious
Flat view
Post (hide subjects) Posted by
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow