Nikon D700, SB-700, Godox Xpro and X1R not working properly

Started 2 months ago | Discussions thread
ForumParentFirstPrevious
Flat view
MichaelRicePhoto
MichaelRicePhoto New Member • Posts: 3
Nikon D700, SB-700, Godox Xpro and X1R not working properly

I know Im probably super late to this but this is really bugging me.  I have a Nikon D700 paired with a SB700, Godox Xpro trigger and Godox X1R.  I have tried literally every way possible to get the Xpro to change the output on the Sb700 via the X1R.  I have been on facebook talking it over with a few people and I am getting mixed information I think.  A few people say that the Godox system will not change the output for the SB700.  The other people keep saying it will but it needs to be in TTL mode.  Problem is, if I put it in TTL mode on the flash, the flash won't fire making me change the output on the back of the flash and not the Xpro.  The only way the flash will fire is in manual mode on the flash.  Ive checked my firmware on the X1R and its V21 which I believe is the most current firmware.  I have no clue what else to do to make this setup work like I thought it should.  Any info would be great! Thank you!

 MichaelRicePhoto's gear list:MichaelRicePhoto's gear list
Nikon D700 Nikon AF Nikkor 50mm f/1.8D Nikon AF Nikkor 85mm f/1.8D Nikon AF-S Nikkor 200-400mm f/4G ED VR II Sigma 120-300mm F2.8 EX DG HSM +2 more
Nikon D700
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow