Hyper-V intrusion on Win10

Started 3 months ago | Discussions thread
OP AnthonyL Veteran Member • Posts: 3,449
Re: Hyper-V intrusion on Win10

afterburn wrote:

AnthonyL wrote:

Just started recently, Win10 Pro, up to date, kb4598242 on 20H2.

First noticed when I loaded an IP scanner and noticed it defaulted to 172.x instead of my usual 192.x IP range. Then I found I had some v-Ethernet connections which I disabled and checked that Hyper-V was disabled in Windows Features.

Turned off overnight as usual and booted up this morning and the v-Ethernet connections are back.

What gives? How to kill it? Why has it started now?

Do you use wsl? Wsl2 uses virtual interfaces for its connectivity.

No - but I had tried Windows Sandbox and removing it got rid of the v_Ethernet connections.

So far so good - EXCEPT:

I had updated to 2021-01 Cumulative Update for Windows 10 Version 20H2 for x64-based Systems (KB4598242 a couple of days ago, then unchecked the Sandbox yesterday (which took ages and a reboot to complete the process). And despite the Update history telling me that I have 2021-01 my machine has slowed to a crawl (Tiworker hitting the system) whilst it installs it again!!

Edit; PS - seems as if the update is completed so I'm not sure what it's done but certainly not the full exercise it needed a few days ago :).  Maybe just checking all components were there - I won't be bothering with Windows Sandbox again anyhow as if I wanted to test any sites the Edge browser provided needed updating each time.

 AnthonyL's gear list:AnthonyL's gear list
Canon EOS 700D Canon EF-S 10-22mm F3.5-4.5 USM Canon EF-S 55-250mm f/4-5.6 IS Canon EF 40mm f/2.8 STM Canon EF-S 18-55mm f/3.5-5.6 IS STM +5 more
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow