Rx10 Mark 4. Oh dear.

Started 3 days ago | Discussions thread
ForumParentFirstPrevious
Flat view
hwvlover
hwvlover Senior Member • Posts: 5,684
Rx10 Mark 4. Oh dear.
3

After over three years (I got it on 1st October 2017) and hundreds of thousands of pics my M4 seems to have died.
I was photographing birds this morning and found I could not replay the images. Oh well, must be the SD card I thought. Unfortunately I then also realised that I could no longer get it to zoom by either the lever or the zoom ring.
I have removed and replaced the battery I have also tried another battery. I cannot access anything, the replay button, the Fn button or the menu button (so doing a reset is not going to happen) do not work. Delete (C3) apparently does as does the shutter.
If anybody has any ideas as to what else I can try they would much appreciated.
This was my last photograph with it (Boo Hoo).

And that explains my dilemma of whether I should get it repaired or simply get another.

Regards,
David
***************************************
Growing old is inevitable; growing up, however, is optional.
And I have opted out.

 hwvlover's gear list:hwvlover's gear list
Panasonic Lumix DMC-FZ200 Panasonic Lumix DMC-FZ300 Sony RX10 IV
Sony Cyber-shot DSC-RX10
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow