RF 70-200 F2.8 Still Front Focusing

Started 4 months ago | Discussions thread
highdesertmesa
highdesertmesa Regular Member • Posts: 455
Re: RF 70-200 F2.8 Still Front Focusing
1

gmanc wrote:

Sounds like you got a lemon. Return it or send it in for repair. This isn't firmware related.

Do you have a RF 70-200 with newer firmware that you’ve tested yourself to know it’s not firmware related? In reading past posts on the subject I didn’t see any that said they updated the firmware and they no longer had a front focus issue.

I do. It's currently at Canon CPS to fix an IS issue or might be slightly decentered. But the focus has always been spot on. You just haven't read far enough – people with the issue report it's gone. It was only an issue at MFD – if yours is not in focus at distance, too, its obviously not the same issue. You'd have RF 70-200 users raising holy hell if every shot was slightly out of focus. I'm done with this thread – you can hold on to your defective lens and wait for a firmware update that will never come, or you can return it or send it for repair. Your choice!

No need to get testy. Counter to your assumption, I did read through every thread I could find and only found one comment where the user ‘thought’ the issue was resolved but wasn’t sure because they hadn’t really tested it yet and many comments that their copy still had issues. That’s why I posted my question. The lens I have is new so it will be returned to the dealer that sold it to me not repaired I was just trying to get feedback from users who had actually owned and tested their copy post firmware upgrade to try to confirm whether it’s a hardware or firmware issue.

The firmware fix did a good enough job for most of us – it's not perfectly split with 50/50 on either side of the focus point, but it's much better than it was before the firmware update. But if your lens is sharper manually-focused at distance – that's a serious issue I've not seen reported before. It sounds more like a mis-aligned lens element or group or possibly a bad circuit board in the lens.

https://www.dpreview.com/forums/thread/4456790?page=2

Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow