Godox X1T-N Problem (Power on X1T and flash output are different)?

Started 2 months ago | Discussions thread
ForumParentFirstPreviousNext
Flat view
CoffeePhotography New Member • Posts: 1
Godox X1T-N Problem (Power on X1T and flash output are different)?

Hello,

Lately I have been getting more and more into flash photography. I have 2 SB-700s with 2 X1R-N receivers and an X1T-N transmitter which sits on top of my D750. I know that in order to control the flash output from the transmitter directly, I have to set the speedlights on TTL (not Manual) and set the transmitter on M (manual). However, I noticed that when I set the transmitter for 1/1 power, the output from the flash is not at 1/1. The way I know that is because of the sound the flash makes when it fires at 1/1 when on top of the camera or when I hit the test button, the flash makes a whistling noise, indicating that it fired at full power. However, it doesn't make the same noise when I fire it with the transmitter set at 1/1 (and flash at TTL). I also tested the flash at manual 1/1 and it fired pretty strongly and overexposed the hell out of the picture but trying the same with the flash on TTL and the transmitter on M and 1/1, the picture wasn't overly exposed, indicating that it did not fire at full power.

I would appreciate any information on this.

Thank you

Nikon D750
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNext
Flat view
ForumParentFirstPreviousNext
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow