Pixpro S-1 with stuck shutter...

Started 2 months ago | Discussions thread
ForumParentFirstPrevious
Flat view
sunnydayz Regular Member • Posts: 102
Pixpro S-1 with stuck shutter...
1

... came back 100% fixed from local camera repair shop.

Got an S-1 via an ebay purchase, took a couple pictures with it and then heard a pretty loud "thunk" of the shutter. At that point the back screen went black, no status icons, the back buttons and control wheel did not function. Could not even turn the camera off, had to take the battery out. On next power up, again the back screen was totally black, but then I pushed the lens release button and then at least the camera status icons appeared and the buttons and control wheel worked. Navigated through the menus to see if there was anything to be done to open the shutter, but nothing found. Shut off the camera and took the lens off to find the shutter was stuck closed.

Sent an email to JK Imaging, but the customer service replied that they do not do repairs, nor do they even have a repair center. Their only option was to replace the camera if it was within the 12 month warranty, which of course my camera was not.

At that point I decided to take it to a local camera repair shop. The guy at the shop at first didn't want to even look at it. I convinced him that it was not a cheap throw away camera. It's an interchangeable lens camera with four thirds sensor after all.

Sorry to drag this story out. Anyway a week and a half later I get a call with a service estimate, which I agreed to. A couple days after that I get another call that the stuck shutter is repaired, but with "generic" parts. The guy said a gear was broken and he was able to source a gear from a some other brand scrap body. He said he wasn't even sure it would work until he put the camera back together, tested it and the shutter was fixed.

He also contacted JK Imaging (probably to try sourcing parts) but was told the same thing they told me, that they would replace it if under warranty.

I'm glad he was able to fix it. The camera is working fine and the shutter seems even quieter now than before. Woohoo!

 sunnydayz's gear list:sunnydayz's gear list
Sony RX100 Fujifilm X100T Sony SLT-A77 Olympus OM-D E-M10 II Olympus PEN-F +14 more
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow