EOS Utility

Started 3 months ago | Questions thread
ashton lamont
ashton lamont Contributing Member • Posts: 635
Re: EOS Utility

John_Hoffman wrote:

Para5thbtn wrote:

When i connect my eso5d to my computer and log on to Eos utility, i get a camera not recognized message. ???? can any one help please.

running windows 10, ACPIx64

You need to go to the Canon support site for Windows Vista (x64) and download EOS Utility 2.7.3 and see if that will work for you.

Yes, if you're using an older 5D such as the 5D Mark II you need to install EOS Utility 2, but for later cams such as the 5D Mark IV you need EOS Utility 3.

-- hide signature --

Pete

Post (hide subjects) Posted by
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow