SL2 EVF-LCD Eye Sensor Problem

Started 2 months ago | Questions thread
ForumParentFirstPrevious
Flat view
amati Contributing Member • Posts: 846
SL2 EVF-LCD Eye Sensor Problem

I just bought a SL2 with 35mm and 75mm SL apo summicrons.
I was on a landscape trip since last 4 days. I enjoyed the system a lot and will be buying 90-280mm soon.

The problem i have is The Evf-Lcd sensor!

When i push my eye on the Evf the live view image is present but when i try to AF the image suddenly blacks out.Then i move away from the EVF and push my eye back image suddenly comes again.I have tried Auto and Evf Extended modes which both have the same problem.This happens mostly outdoor and well lit scenes but never indoors.(more if sun is present in the scene )When i choose EVF-only option this problem never happens which i think closes the eye sensor.So i think this is an eye sensor problem.A friend of mine who has SL2 has the same problem which makes feel that it is maybe a firmware problem.I tried to clean the sensor and restart the camera to factory defoults but did not help.
Do you have a suggestion to solve this problem?
Best
Ahmed Gencal

 amati's gear list:amati's gear list
Leica M Typ 240 Leica Macro-Elmar-M 90mm f/4 Leica APO-Summicron-M 50mm f/2 ASPH Fujifilm GF 110mm F2
ANSWER:
This question has not been answered yet.
Canon EOS Rebel SL2 (EOS 200D / Kiss X9)
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow