Eos R5 hot shoe corrosion after one shooting in light rain

Started 3 months ago | Discussions thread
ProDude Senior Member • Posts: 1,955
Re: Could you send a slightly bigger (larger area) image

MyM6II wrote:

KariP wrote:

iker3085 wrote:

Last weekend I took my 1 week old R5 on a shooting during light rain. Afterwards I dried it with a towel. Today I saw that one small part of the hot shoe shows corrosion. I've never had that before, my 6d Mark II and my 1DX, that I used during rain several times in the past years, never showed something similar. Any ideas what to do here?

I really would like to see 5 cm more to every direction - the explanation to this problem could be in a bit larger image of the cameras top plate ....

And I just started to wonder why you did not send the camera back to Canon - I would have done that immediately.

When seeing this photo, my first thought was acid. Maybe a leak battery in a speedlight or something ?

I was thinking the same thing. I've seen that greenish deposit before when having a leaky battery from the acids they emit. Hmmmm in a way I'd be happy to find that being the case. It would let Canon off the hook for shear water intrusion issues.

-- hide signature --

Name the gear and I've probably owned it and used it.

 ProDude's gear list:ProDude's gear list
Canon EOS R5 Sigma 14-24mm F2.8 DG HSM Art Sigma 105mm F1.4 DG HSM Art Canon RF 24-70mm F2.8L IS USM Canon RF 70-200mm F2.8L IS USM +17 more
Post (hide subjects) Posted by
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow