OMD E-M1 ii Front Dial - Stiff Vague Mushy Rubbery

Started 1 month ago | Questions thread
ForumParentFirstPreviousNext
Flat view
HalftoneDot New Member • Posts: 6
OMD E-M1 ii Front Dial - Stiff Vague Mushy Rubbery

Bought an E-M1 Mark ii to take advantage of recent PRO Lens offer.

However, the Front Dial has a completely different feel to Rear Dial. The front is stiff vague and imprecise in operation, with poor tactile feel. Both front and rear sound just as loud.

For comparison, I Also Have an E-M1 i, E-M10 i, 2x ii and iii - and these all had same feel and response between their front and rear dials (no difference felt). Also have number of Canon EOS 1 series cameras, and dials again feel same, front and rear, both landscape or portrait orientation, no difference between each dial on these cameras..

Rear dial is fine on this new EM1 ii and the rear dial, feels just like the front & rear dial on E-M1 mk I.

Any thoughts ?? Is the difference there for a reason on EM1 ii, but not on the others ?? Or could rubber weather sealing be out of place and rubbing, or does it have an internal tension/resistance adjustment for the dial ?? Or is some over librication the cause ??

if it’s a wrongly fitted weather seal, I may not be able to enjoy a shower with it - without front dial leaking.

ANSWER:
This question has not been answered yet.
Olympus E-M1 Olympus OM-D E-M10
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNext
Flat view
Post (hide subjects) Posted by
ForumParentFirstPreviousNext
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow