Trouble with my DP2Q

Started 3 months ago | Discussions thread
Tom Schum
Tom Schum Forum Pro • Posts: 10,277
Re: Trouble with my DP2Q

victorgv wrote:

Ovid46 wrote:

Hi All.

Have had trouble with the 5 year old DP2Q. The wheels on the top go around and the fStop and shutter speed go berserk. Sent the camera to 'Japan Camera Repair' in Atlanta Ga. for repair. Got the camera back, took a dozen pictures and it worked fine. Put it away for 3 months and just tried it again (and again) and it has the same malfunctions.

I've seen some previous posts about this problem. Am wondering if anyone had their camera repaired and what the results were. I did try cleaning it as someone suggested, but it was only a temporary fix.

Any suggestions or comments most welcome.

Richard

I took it apart , bend contacts slightly! so they would move out of groove and will pressure contact pads slightly more and cleaned/lubricated it with "contact pro gold" .

Never since.

I have tools and Caig F-series Fader Deoxit liquid.  Taking apart my dp0q is a little bit scary for me.  Is it difficult?

I've so far been able to remedy the dial intermittencies by rotating the dials with power off.  Rotate them at least 25 times.  This improves things temporarily.

-- hide signature --

Tom Schum
Copper: Mankind's favorite electrical conductor

 Tom Schum's gear list:Tom Schum's gear list
Fujifilm X30 Sigma dp0 Quattro Panasonic ZS100 Fujifilm X-E1 Sigma sd Quattro +15 more
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow