Fuji X100F on/off switch not moving freely

Started 2 months ago | Discussions thread
ForumParentFirstPrevious
Flat view
TheChappie
TheChappie Regular Member • Posts: 313
Fuji X100F on/off switch not moving freely

Hey everyone,

I'm having an issue after coming home from a trip that my X100F is not freely turning on and off.  It takes quite a bit of force to turn it off, and turning it on is not as simple as a flick like it was before.  I stored it in my bag for the trip home, but I'm afraid some sand granules or something of that nature may have lodged inside it.  The camera was working perfectly fine prior to storage. I have tried using floss, as well as air (not from a can, but from an air tool in a workshop) and have not been able to do more than possibly move the granule in question, which has helped with flipping it on but not off.

My question I suppose is has anyone experienced this before and what did you do if so? Also, can anyone provide a detailed diagram or guide on disassembling the X100F that includes taking apart the shutter release & on/off toggle?

-- hide signature --

Try to set the night on fire...
I dare you.

 TheChappie's gear list:TheChappie's gear list
Sony a7R II Fujifilm X100F Fujifilm X-Pro3 Fujifilm XF 27mm F2.8 Fujifilm 16-55mm F2.8R LM WR
Fujifilm X100F
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow