G9 massive EVF lag in lower light

Started 1 month ago | Discussions thread
ForumParentFirstPrevious
Flat view
Carol T Senior Member • Posts: 1,019
G9 massive EVF lag in lower light
2

Hi, I have a questions for users of the G9. I experience really bad lag in my EVF when the light is at all low. Not even what I would consider low light, just less that bright. Certainly not dark condition. Even small movements of my camera or my subject completely disrupt the EVF image, and it doesn't stabilize very fast.

OTOH, my older E-M1 (original) has very little of this lag under the same conditions. I realize the resolution is somewhat lower, and it is LCD vs OLED, but wow. I guess I expected better from the G9.

I have the refresh rate set at 120 Hz currently, and that does help a bit compared with the 60 Hz setting, but it is still very inconvenient. The lag is so bad it makes it impossible to follow anything moving.

I am wondering what other people have experienced with the G9 in this regard. Is there something wrong with my camera? Or is this just normal for this model? Any suggestions? I love this camera otherwise, is just amazing, so I am hoping I can find a way to make the EVF a bit more usable in less-than-perfect conditions.

Thanks!

Olympus E-M1 Panasonic Lumix DC-G9
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow