Aperture w/ Command Dial Not Working on X-T2

Started 2 months ago | Questions thread
fujiian
OP fujiian Regular Member • Posts: 193
Re: Aperture w/ Command Dial Not Working on X-T2

Erik Baumgartner wrote:

fujiian wrote:

Erik Baumgartner wrote:

The aperture can only be controlled with the rear command dial on the X-T2 (using a lens with an aperture ring).

1) You will have to assign APERTURE SETTING to the rear command dial

2) The aperture ring must be set to "A"

3) The shutter dial can't be set to "T"

Thank you, Erik – this is helpful to know that 'T' plays a role here.

I gave it a spin and, unfortunately, this does not solve the issue. Here are my settings:

  • Aperture on 'A'
  • Command Dial setting > SS (front), F (rear)
  • Fn/AE-L/AF-L settings > Rear Dial > Aperture setting

Pretty sure you have to have SS on the rear dial, F on the front.

I much prefer using the aperture ring to a dial (after my muscle memory from early days kicked back in) , but if I did want to control the aperture will a dial, I wouldn't be happy. Fuji definitely messed that up the setup possibilities for that - I would want to use the front dial for aperture (my aperture-ringless NIkons had SS on the rear and aperture on the front.

Agreed – the rings are the way to go – I just want to make sure my camera is able to do this in case I buy a ringless lens (viltrox 85, 27mm pancake, etc).

Unfortunately the SS/F configuration, added to the list above, also doesn't seem to solve the issue :/

 fujiian's gear list:fujiian's gear list
Fujifilm X-T2 Fujifilm XF 35mm F1.4 R Fujifilm XF 14mm F2.8 R Fujifilm XF 55-200mm F3.5-4.8 R LM OIS Fujifilm 16-55mm F2.8R LM WR +3 more
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow