em5.3 baseplate cracked/broken around tripod mount

Started 1 month ago | Discussions thread
ForumParentFirstPrevious
Flat view
pukha23 New Member • Posts: 14
em5.3 baseplate cracked/broken around tripod mount
10

i keep my arca tripod mounting plate (from the PD capture clip) always connected to my camera, as i use the tripod alot and the PD capture clip sometimes. last night as i was attaching to my tripod, i noticed that the connection felt a little wiggly. i removed the mounting plate and found that the (plastic) baseplate of my em5.3 was cracked quite extensively!

cracked baseplate of my em5.3

i don't know when this happened, but assume it progressed over time as there have been no impact or obviously stressful events that i am aware of. i did find a couple other dpreview threads where similar damage was discussed. yes i have used the pd capture clip to mount the camera on a shoulder strap while hiking/ backpacking, though not likely more than 20 or so miles in total thus far. the heaviest lens in this use case would be the mz 12-40 pro. it has spent substantially more time mounted on a tripod, with the 75-300 ii likely giving the most torque.

neither of these are large / heavy lenses, nor is the em5.3 a massive body. the reason i bought into this system was very much centered around the light weight and specifically the use case of carrying the camera on long hikes / backpacking, in easy reach with the pd capture clip. so... yes i am feeling very frustrated at the moment.

i have just submitted a warranty claim and plan to send this in on monday. i really hope that a) it is covered by warranty and b) they can repair quickly. i spent quite a sum on this camera in november and have a lot of plans for it in the coming weeks and months.

anyhow, if the baseplate / mount design is inadequate for this use case (hiking with the pd capture clip) i will... i don't know what. there isnt another m43 camera (that i'm aware of) with this guys capabilites, weather sealing, and light weight. i guess i could sell it and go for a em5.2 (with metal baseplate), but i don't want to give up the improved autofocus.

i am wondering if it is possible the cracking has resulted from overtorquing the mounting plate screw. it doesn't seem likely but it is plausible. i suppose it is even possible that this is the result of bad luck and a rare defective unit. (maybe)

ForumParentFirstPrevious
Flat view
Post (hide subjects) Posted by
NCV
NCV
NCV
NCV
NCV
NCV
NCV
NCV
NCV
NCV
NCV
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow