Can't get Hahnel Captur to work on D500

Started 1 month ago | Discussions thread
ForumParentFirstPrevious
Flat view
skutters Contributing Member • Posts: 643
Can't get Hahnel Captur to work on D500

Hi,

I have just bought a Hahnel Captur Pro set and a Transmitter and Receiver set to have a go at some remote shooting of the birds that come to my feeders, i just can't get them to work.  I have the Pro Module set to IR, the transmitter in the camera hotshoe and the receiver connected to the camera via the supplied cable for the camera and a flash in the receiver hotshoe, If i break the IR beam the flash will fire but not the shutter?.

I have tried just firing the shutter by connecting the receiver to the camera with the cable and pressing the large button on the transmitter but nothing happens.  I can't figure out what i an doing wrong i have looked on the web site and looked at videos and they just connect them the way i have.  I am stumped so any suggestions would be appreciated.

Regards Kev.

 skutters's gear list:skutters's gear list
Fujifilm XF 18-55mm F2.8-4 R LM OIS Fujifilm XF 55-200mm F3.5-4.8 R LM OIS Nikon 200-500mm F5.6E ED VR Fujifilm X100S Nikon D500 +3 more
Nikon D500
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
Post (hide subjects) Posted by
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow