Same camera body, different results?

Started 1 month ago | Discussions thread
ForumParentFirstPrevious
Flat view
CassR Regular Member • Posts: 133
Same camera body, different results?
1

A little while ago I bought a refurbished x100f from Fuji.

I fell in love with that camera. Unfortunately however, I had to send it back to them as it had dust in the EVF.

They promptly sent a replacement but it was in quite a bit worse condition, much higher shutter count and had lots of dust in the OVF.

They sent a third replacement which was thoroughly checked over and had no dust issues. Shutter count was somewhere between the first two I received.

This may sound ridiculous but what's happening now is I miss the first one I received. Apart from the dust I really connected with it, it had a "magic" quality to it.

It may well be that the process of sorting the issue out took the shine off, but my question is, is it possible that two of the same camera bodies can differ in any meaningful way?

I saved all my settings from the original so it's set up the same.

My new one works exactly as it should and there is nothing at all wrong with it.

I like it very much, but that first one...

I realise that I may well be going covid crazy and that what I am describing isn't a problem at all in the grand scheme of things!

Fujifilm FinePix X100 Fujifilm X100F
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow