So my GFX100 won't update...

Started 1 month ago | Discussions thread
ForumParentFirstPrevious
Flat view
MikeB_2018 Regular Member • Posts: 317
So my GFX100 won't update...

So, I downloaded the new v.2.0 firmware.  Installed fresh batteries.  Formatted both cards in both slots.  Loaded the new firmware (correct version) onto the SD card via the computer.  Put the SD card back into the GFX100.  Made sure the camera was reading from that slot (slot 1).  But won't update.

Here's the thing.  Even just trying to check the current firmware version I have on the camera, as per Fuji's advice to "hold down the 'DISP/BACK' button while turning the camera on," isn't working.  I see no firmware info and the camera just turns on as usual.  (I made sure I didn't have the buttons locked, so that's not the issue).

So then when you are supposed to do the same thing once the SD card has the new firmware loaded I again get nothing but the usual shooting mode.  I looked all over and couldn't find any FAQ info about this on Fuji's site.

The camera has been working fine, and I updated it/lenses before and it all worked.  But not sure why now I can't get it to open the firmware dialogue.

Anyone here run into this before and find a resolution?  Or any alternatives to get into that firmware dialogue?  I feel I've exhausted all my other options other than calling Fuji.  Just thought someone here might know?

 MikeB_2018's gear list:MikeB_2018's gear list
Canon PowerShot G10 Canon EOS-1Ds Mark III Canon EOS 5D Mark III Canon EOS 5D Mark IV Canon EOS R +30 more
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow